PDA

View Full Version : Errors after Installation



webguy76
10-02-2006, 11:11 AM
I have the following errors after installing:



Warning: chdir(): No such file or directory (errno 2) in /home/wgreen/public_html/directory/links_global.php on line 17

Warning: main(./global.php): failed to open stream: No such file or directory in /home/wgreen/public_html/directory/links_global.php on line 52

Fatal error: main(): Failed opening required './global.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/wgreen/public_html/directory/links_global.php on line 52


I figured that I did something wrong during installation, so I uninstalled the script and started over -- but more carefully. I got the same message again.

I don't know what could be wrong. The only think I can think of is that I have my forums installed in /community and I have my link directory installed in /directory -- would that make a difference? I did make sure that I entered the relevant paths and URL's during installation.

I have the forums and the free portal working fine.

Can someone tell me what the above errors mean?

webguy76
10-02-2006, 11:16 AM
Oh - never mind. I had the path wrong (duh).

Our Sponsors
 

webguy76
10-02-2006, 11:23 AM
Ok now I have a new problem.

I have the portal installed in the root (I renamed it to portal.php):

/portal.php

I have the link directory installed in the root:

/directory

I have the forums installed in the root:

/community

However, the forum images are showing fine. But the forum links are not being displayed in the portal or the directory. When I hover over the images they say:

Portal:
http://www.mywebsite.com/images/c2/c2_17.jpg

Directory:
http://www.mywebsite.com/directory/images/c2/c2_09.jpg

instead of:
http://www.mywebsite.com/community/images/c2/c2_17.jpg

What can I do?

webguy76
10-02-2006, 11:34 AM
I checked and both portal.php (originally cmpd_index.php) and /directory/links_config.php both have:

$forumpath = '/home/wgreen/public_html/community';

..which is correct, yet the images are not showing.

Our Sponsors
 

webguy76
10-02-2006, 11:39 AM
I think I know what's wrong. The skin I am using is using hald relative paths and half full paths. I will have to go through the template and correct it.

webguy76
10-02-2006, 11:45 AM
Yep -- It was the skin. Thanks for your help!

Brian
10-02-2006, 12:12 PM
Glad you were able to get things worked out. :)

simsnet
12-10-2006, 12:34 PM
Hi,

I have the same problem after installing files.

Warning: main(./global.php): failed to open stream: No such file or directory in mypath/forum/admincp/vbalinks_install.php on line 18

Fatal error: main(): Failed opening required './global.php' (include_path='.:/usr/local/lib/php') in my path/forum/admincp/vbalinks_install.php on line 18

The server path is exactly the same as in my CMPS index file and that is working fine. Any ideas? I have cancelled out the path and put mypath instead but the path is 100% fine. Im using vb 3.6.4

simsnet
12-10-2006, 04:10 PM
solved the problem, somehow i deleted some admin files.

I reinstalled them and the installation went ok.