PDA

View Full Version : News module displaying hidden threads...



Sanjiyan
07-26-2007, 06:15 PM
Hiya,

I do not know why it is doing this but I have setup the news module to display threads from various forums..

Several of which require permissions to view them, but the news module seems to be ignoring the permissions and is displaying both public and private news on the front page... to everyone even unregistered users.

If a guest clicks on a news link, only then does it say enter your username/password.

Any ideas why this is? the Apply Forum Permissions radio button is set to yes.

Sanjiyan
07-28-2007, 10:38 AM
Anyone got any ideas?

Our Sponsors
 

Brian
07-28-2007, 01:03 PM
Did you make sure that the 'Initialize Forum Permissions' option with the news module was enabled as well? And can you post a link to your site?

Sanjiyan
07-30-2007, 03:46 PM
Yep, Brian here you go..

http://www.eve-atf.com/

Its displaying as news a forum which is accessible by a member user group... yet on the front page its there :(

Our Sponsors
 

Brian
07-31-2007, 10:20 AM
That may be related to the issue pointed out here (http://www.vbadvanced.com/forum/showpost.php?p=118160&postcount=4).

Sanjiyan
07-31-2007, 02:42 PM
Nope sorry I did the change, and it didnt help.

Your welcome to see.. click the above link :)

Brian
08-01-2007, 11:28 AM
I'm not really sure what else could cause that then. If you'd like to submit a support ticket via the Members' Area here though I'll be glad to take a look at things for you.

Sanjiyan
08-01-2007, 01:09 PM
sure thing, doing that now.

Brian
08-01-2007, 02:07 PM
For anyone else that may be having a problem with permissions in their news module, the download package here has just been updated to include a fix. Please download the files from here again, replace your modules/news.php file with the one from there, and that should take care of the issue.