Results 1 to 5 of 5

Thread: Jump to latest post (lastpost) does not work?

  1. #1

    Question Jump to latest post (lastpost) does not work?

    Hello,

    i've upgraded to vb362 and vbadvanced 220 today. I have the LATESTTOPICS module and since yesterday i was able to jump to the last post of a topic instead of the first post. I used the parameter /forum/showthread.php?goto=lastpost&t=1136 for it.

    This does not work anymore? I always get to the first page of the thread. Does anyone know how to fix this?

  2. #2
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default Re: Jump to latest post (lastpost) does not work?

    No, "goto=lastpost" no longer works in vB 3.6. If you'll replace the contents of your 'adv_portal_latesttopicbits' template with this though, that should take care of the problem.

    Code:
    <if condition="$mods['modcol'] == 1">
    
    	<tr>
    		<if condition="$mod_options['portal_threads_showicon']">
    			<td class="alt2"><if condition="$show['threadicon']"><img alt="" border="0" src="$thread[threadiconpath]" title="$thread[threadicontitle]" /></if></td>
    		</if>
    
    		<td class="alt1">
    			<if condition="$thread['subscribed']">
    				<span style="float:$stylevar[right]"><img alt="" class="inlineimg" src="$stylevar[imgdir_misc]/subscribed.gif" title="$vbphrase[you_are_subscribed_to_this_thread]" /></span>
    			</if>
    			<a href="$vboptions[bburl]/showthread.php?t=$thread[threadid]" title="$thread[preview]"><if condition="$show['gotonewpost']"><strong>$thread[title]</strong><else />$thread[title]</if></a>
    
    			<if condition="$thread['rating']">
    				<span style="float:$stylevar[right]"><img alt="" src="$stylevar[imgdir_rating]/rating_$thread[rating].gif" title="<phrase 1="$thread[votenum]" 2="$thread[voteavg]">$vbphrase[thread_rating_x_votes_y_average]</phrase>" /></span>
    			</if>
    
    		<div class="smallfont"><span style="cursor:pointer" onclick="window.open('$vboptions[bburl]/member.php?$session[sessionurl]u=$thread[postuserid]')">$thread[postusername]</span>
    
    		</div>
    		<if condition="$mod_options['portal_threads_showdate']"><div class="smallfont">$thread[postdate] $thread[posttime]</div></if>
    		</td>
    		<if condition="$show['lastpost']">
    			<td class="alt2">
    				<div class="smallfont" style="text-align:right; white-space:nowrap">$thread[lastpostdate] <span class="time">$thread[lastposttime]</span><br /><phrase 1="$vboptions[bburl]/member.php?$session[sessionurl]find=lastposter&amp;t=$thread[threadid]" 2="$thread[lastposter]">$vbphrase[by_x]</phrase> <a href="$vboptions[bburl]/showthread.php?$session[sessionurl]p=$thread[lastpostid]#post$thread[lastpostid]"><img alt="" border="0" src="$stylevar[imgdir_button]/lastpost.gif" title="$vbphrase[go_to_last_post]" /></a></div>
    			</td>
    		</if>
    		<td align="center" class="$class_reply"><span class="smallfont">$thread[replycount]</span></td>
    
    		<td align="center" class="$class_view"><span class="smallfont">$thread[views]</span></td>
    			<if condition="$mod_options['portal_threads_showforum']">
    				<td class="$class_ftitle"><span class="smallfont"><a href="$vboptions[bburl]/forumdisplay.php?$session[sessionurl]f=$thread[forumid]">$thread[forumtitle]</a></span></td>
    			</if>
    	</tr>
    
    <else />
    
    	<tr>
    		<td class="$bgclass">
    			<if condition="$show['threadicon']">
    				<img alt="" src="$thread[threadiconpath]" border="0" title="$thread[threadicontitle]" />
    			</if>
    			<if condition="$thread['subscribed']">
    				<img alt="" class="inlineimg" src="$stylevar[imgdir_misc]/subscribed.gif" title="$vbphrase[you_are_subscribed_to_this_thread]" />
    			</if>
    			<span class="smallfont"><a href="$vboptions[bburl]/showthread.php?t=$thread[threadid]" title="<if condition="$thread[preview]">$thread[preview]
    
    </if>$vbphrase[by] $thread[postusername] <if condition="$mod_options['portal_threads_showdate']">$thread[postdate] $thread[posttime]</if>"><if condition="$show['gotonewpost']"><strong>$thread[title]</strong><else />$thread[title]</if></a></span>
    
    			<if condition="$thread['rating']">
    				<div style="margin-top:4px"><img alt="" src="$stylevar[imgdir_rating]/rating_$thread[rating].gif" title="<phrase 1="$thread[votenum]" 2="$thread[voteavg]">$vbphrase[thread_rating_x_votes_y_average]</phrase>" /></div>
    			</if>
    			<if condition="$show['lastpost']">
    				<div class="smallfont" style="margin-top:4px"><a href="$vboptions[bburl]/showthread.php?$session[sessionurl]p=$thread[lastpostid]#post$thread[lastpostid]"><img alt="" border="0" src="$stylevar[imgdir_button]/lastpost.gif" title="$vbphrase[go_to_last_post]" /></a> $vbphrase[last_post_by] <a href="$vboptions[bburl]/member.php?find=lastposter&amp;t=$thread[threadid]">$thread[lastposter]</a></div>
    				<div class="smallfont">$thread[lastpostdate] <span class="time">$thread[lastposttime]</span></div>
    			</if>
    
    			<if condition="$mod_options['portal_threads_showforum']">
    				<div class="smallfont"><a href="$vboptions[bburl]/forumdisplay.php?$session[sessionurl]f=$thread[forumid]">$thread[forumtitle]</a></div>
    			</if>
    		<div class="smallfont">$thread[replycount] $vbphrase[replies], $thread[views] $vbphrase[views]</div></td>
    	</tr>
    </if>

  3. #3

    Default Re: Jump to latest post (lastpost) does not work?

    Thanks Brian!

  4. #4
    Join Date
    May 2006
    Posts
    174

    Default Re: Jump to latest post (lastpost) does not work?

    im having problems w/ this code. it messes up my cell colors in the last 3 colums in the recent threads module. but the links work.

  5. #5
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default Re: Jump to latest post (lastpost) does not work?

    What version of the CMPS are you running?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. last post doesn't work at latest threads
    By Hexemer in forum Troubleshooting & Problems
    Replies: 1
    Last Post: 08-29-2006, 07:37 AM
  2. new post search doesnt work...
    By nexus851 in forum Troubleshooting & Problems
    Replies: 1
    Last Post: 11-15-2005, 12:51 PM
  3. Latest threads on CMPS - takes to post #1 not latest post
    By Viks in forum Troubleshooting / "How do I..." Questions
    Replies: 11
    Last Post: 02-16-2005, 02:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •