Results 1 to 19 of 19

Thread: cmps_index.php in root problem.

  1. #1
    Junior Member
    Join Date
    Sep 2006
    Posts
    8

    Default cmps_index.php in root problem.

    Hi my problem is, i installed vbadanced in /forums where my forum root is. I then tried to put my cmps_index.php in the / so that the first thing they come to is that (yes i renamed it to index.php, yes and changed it in the default in the admin cp). I know there is nothing wrong with my installation because once i moved the cmps_index.php to the /forum it worked. I tried changing ./include and ./global to ./forum/include and ./forum/global but it still does not work. Any suggestions on what I have to do to fix this?

    Thank you.

  2. #2
    Administrator Brian's Avatar
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,434

    Default Re: cmps_index.php in root problem.

    How exactly does it not work? What happens when you load the page?

  3. #3
    Junior Member
    Join Date
    Sep 2006
    Posts
    8

    Default Re: cmps_index.php in root problem.

    I get a blank page. It loads, but stays blank. Do you think it might be because I uploaded the cmps_index.php after I installed vdadvanced? Thats all I can really think of.

  4. #4
    Junior Member
    Join Date
    Nov 2006
    Posts
    3

    Default Re: cmps_index.php in root problem.

    I'm getting a similar problem.

    The only difference is that my page actually loads, however the links on the cmps_index.php page are all pointing to the root directory not the /forum directory.

    I've checked my config.php and the directory in the cmps_index.php file and they are both showing the same directory for the forum.

  5. #5
    Administrator Brian's Avatar
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,434

    Default Re: cmps_index.php in root problem.

    seaslash - Sounds like your $forumpath variable in the cmps_index.php file is incorrect. Please try the suggestions in this thread and see if that helps.

    Kwith - Please see this thread.

  6. #6
    Junior Member
    Join Date
    Sep 2006
    Posts
    8

    Default Re: cmps_index.php in root problem.

    Quote Originally Posted by Brian View Post
    seaslash - Sounds like your $forumpath variable in the cmps_index.php file is incorrect. Please try the suggestions in this thread and see if that helps.

    Kwith - Please see this thread.
    No I tried that already . I have no idea whats wrong.

  7. #7
    Junior Member
    Join Date
    Nov 2006
    Posts
    3

    Default Re: cmps_index.php in root problem.

    Thanks Brian.

  8. #8
    Administrator Brian's Avatar
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,434

    Default Re: cmps_index.php in root problem.

    Quote Originally Posted by seaslash View Post
    No I tried that already . I have no idea whats wrong.
    Can you copy that line of code and paste it here for me?

  9. #9
    Junior Member
    Join Date
    Sep 2006
    Posts
    8

    Default Re: cmps_index.php in root problem.

    Quote Originally Posted by Brian View Post
    Can you copy that line of code and paste it here for me?
    /home/users/web/b2740/pow.firefly09/htdocs

    Its' powweb's stupid custom job. I honestly dont think thats the problem because if i add /forum and move it to the forum folder it works perfect.

    You dont think it has anything to do with the includes it has to load?
    Last edited by seaslash; 11-13-2006 at 07:07 PM.

  10. #10
    Junior Member
    Join Date
    Nov 2006
    Posts
    8

    Default Re: cmps_index.php in root problem.

    Shouldn't you have /forum no matter where the file is on your site? It's pointing to where your forums are located.

  11. #11
    Administrator Brian's Avatar
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,434

    Default Re: cmps_index.php in root problem.

    As catcherman said, it needs to have /forum at the end.

    /home/users/web/b2740/pow.firefly09/htdocs/forum

  12. #12

    Default Re: cmps_index.php in root problem.

    hi all
    im new to this portal system and i get the same problem i get this error while im trying to view the main index.php

    Parse error: parse error in C:\Inetpub\vhosts\ml-profiles.co.uk\httpdocs\forum\cmps_index.php on line 30

  13. #13
    Administrator Brian's Avatar
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,434

    Default Re: cmps_index.php in root problem.

    That means that you've modified the file incorrectly. Can you post the contents of your cmps_index.php file here?

  14. #14

    Default Re: cmps_index.php in root problem.

    ya sure
    Here it is
    PHP Code:
    <?php
    // ++=========================================================================++
    // || vBadvanced CMPS v2.2.1 (vB 3.6) - 41481
    // || © 2003-2004 vBadvanced.com & PlurPlanet, LLC - All Rights Reserved
    // || This file may not be redistributed in whole or significant part.
    // || http://vbadvanced.com
    // || Downloaded 14:13, Thu Nov 16th 2006
    // || 
    // ++ ========================================================================++

    error_reporting(E_ALL & ~E_NOTICE);
    define('NO_REGISTER_GLOBALS'1);
    define('THIS_SCRIPT''adv_index');
    define('VBA_PORTAL'true);
    define('VBA_SCRIPT''CMPS');

    // ============================================
    // Enter the full path to your forum here
    // Example: /home/vbadvanced/public_html/forum
    // ============================================

    //$forumpath = 'C:\\Inetpub\\vhosts\\ml-profiles.co.uk\\httpdocs\forum'

    $forumpath '/httpdocs/forum'

    // ============================================
    // No Further Editing Necessary!
    // ============================================

    if ($forumpath)
    {
        if (!
    is_dir($forumpath))
        {
            echo 
    'Invalid forum path specified! Please edit this file and be sure to include the correct path for your $forumpath variable.';
            exit;
        }

        
    chdir($forumpath);
    }

    $phrasegroups = array();
    $globaltemplates = array();
    $actiontemplates = array();
    $specialtemplates = array();

    require_once(
    './includes/vba_cmps_include_template.php');
    require_once(
    './global.php');

    print_portal_output($home);

    ?>

  15. #15
    Administrator Brian's Avatar
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,434

    Default Re: cmps_index.php in root problem.

    Change this:
    Code:
    $forumpath = '/httpdocs/forum'
    To this:
    Code:
    $forumpath = '/httpdocs/forum';
    (just adding the ";" mark at the end)

  16. #16

    Default Re: cmps_index.php in root problem.

    omg !!!! jsut 1 little thing that messed it up ! Lmao thanks alot now it working

  17. #17
    Junior Member
    Join Date
    Nov 2006
    Posts
    2

    Default Re: cmps_index.php in root problem.

    Getting probem...
    I have tried this...but could not fixed!!
    in /home/my site name/public_html/cmps_index.php on line 22

    i have not put .com .so how i can fixed this!!

  18. #18
    Junior Member
    Join Date
    Nov 2006
    Posts
    2

    Default Re: cmps_index.php in root problem.

    Here's it show

    Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /home/antu/public_html/cmps_index.php on line 22

  19. #19
    Administrator Brian's Avatar
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,434

    Default Re: cmps_index.php in root problem.

    Can you post the contents of your cmps_index.php file?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vba in root with vBB in sub domain - problem with images not showing
    By Mojito in forum Troubleshooting & Problems
    Replies: 2
    Last Post: 10-07-2006, 02:05 PM
  2. root directory problem
    By FalkinPro1 in forum Troubleshooting & Problems
    Replies: 1
    Last Post: 07-16-2006, 02:59 PM
  3. help.....moving cmps_index.php file to root messes everything up
    By iamme in forum Troubleshooting & Problems
    Replies: 2
    Last Post: 04-26-2006, 07:30 AM
  4. Problem when cmps_index.php is in root folder
    By chris g in forum Troubleshooting & Problems
    Replies: 7
    Last Post: 07-12-2005, 04:36 PM
  5. error when placing cmps_index.php in root dir
    By brad007 in forum Troubleshooting & Problems
    Replies: 4
    Last Post: 06-30-2005, 12:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •