Results 1 to 2 of 2

Thread: Bug: Avatar showed without permission

  1. #1
    Join Date
    Jun 2004
    Posts
    122

    Default Bug: Avatar showed without permission

    Description
    The Welcome Block shows the users avatar even if he does not have permission

    Steps to reproduce
    1) Setup a User that has a usergroup that allows custom avatars and make sure that Keep Custom Avatar in user manager is set to No
    2) Upload an avatar for this user
    3) Check the welcome module - avatar is being shown
    4) Change usergroup permissiosn for this user so he does not have permission to use custom avatars
    5) Check the welcome module - avatar is still being shown

    Fix
    Needs to check Bitfield genericpermissions & canuseavatar and userinfo[adminavatar]
    To avoid queries, this should be done before calling fetch_avatar_url()

  2. #2
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default Re: Bug: Avatar showed without permission

    Thank you for pointing this out. I'll be sure it's corrected with the next release.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. no permission
    By Bannerhangout in forum Troubleshooting & Problems
    Replies: 9
    Last Post: 03-10-2006, 01:47 AM
  2. Avatar in module news don't display (option avatar actived)
    By Paulo in forum Troubleshooting & Problems
    Replies: 3
    Last Post: 02-03-2006, 04:59 PM
  3. How do I display profile picture/avatar instead of normal avatar for news?
    By baptizer in forum Troubleshooting / "How do I..." Questions
    Replies: 3
    Last Post: 06-09-2005, 12:17 AM
  4. no permission message
    By indie in forum Troubleshooting / "How do I..." Questions
    Replies: 3
    Last Post: 02-24-2005, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •