Page 2 of 4 FirstFirst 1234 LastLast
Results 21 to 40 of 65

Thread: vBulletin Forums Importer

  1. #21
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default Re: vBulletin Forums Importer

    As far as I'm aware it will.

  2. #22

    Default

    Quote Originally Posted by rollinjunk View Post
    I then got this




    and this is the error i got


    Database error in vBulletin 3.6.2:

    Invalid SQL:
    INSERT INTO adv_dyna_entries (entryid, title, catid, userid, username, dateline, views, posts, iconid, valid, open, sticky, showsignature, votenum, votetotal, ipaddress) VALUES (
    1,
    'lookin\' good...',
    3,
    '4',
    'johnnyblaze036',
    '1170949274',
    '36',
    '0',
    '0',
    '1',
    '1',
    '0',
    '0',
    '0',
    '0',
    '208.196.60.42'
    );

    MySQL Error : Duplicate entry '1' for key 1
    Error Number : 1062
    Date : Tuesday, September 25th 2007 @ 08:10:34 AM
    Script : http://dev.bapetalk2.com/admincp/vba....php?do=import
    Referrer : http://dev.bapetalk2.com/admincp/vba...o=submitforums
    IP Address : 66.108.233.115
    Username : rollinjunk
    Classname : vB_Database
    Quote Originally Posted by Brian View Post
    Sounds like you had already submitted some entries to vBa Dynamics, and you have some threads/posts with conflicting id's. If you'll run these queries through phpMyAdmin or your vBulletin Admin CP then it should clear out all of that data.

    TRUNCATE adv_dyna_entries;
    TRUNCATE adv_dyna_entries_pages;
    TRUNCATE adv_dyna_attachments;
    TRUNCATE adv_dyna_entryparsed;
    TRUNCATE adv_dyna_posts;
    TRUNCATE adv_dyna_rate;
    Quote Originally Posted by RaZor Edge View Post
    Will this also work with 3.7.x?


    Brian, I imported a forum to a new category i created, and then ran the maintenence to update counters but got similar to this error. Ive tried running the queries you gave, but get

    An error occurred while attempting to execute your query. The following information was returned.
    error number: 1146
    error desc: Table 'DATABASENAME_ibp.adv_dyna_entries' doesn't exist

    Ive also noticed you cannot make a reply either, You can click the reply button, enter comment etc, but but when you submit it, No comments are being recorded. Ive ran maintenence options too.

    Everything else with dynamics appears to work fine
    Last edited by Magz; 08-09-2008 at 12:28 PM.

  3. #23
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    Looks like you need to add your table prefix before the table names in those queries.

    Code:
    TRUNCATE prefix_hereadv_dyna_entries;

  4. #24

    Default

    Thank you brian, that seemed to work.

    However, i still cant post any comments. You enter a comment, press submit, no errors are shown, but it goes back to the post and the comment isnt being displayed.

    Also, after running the query, content i had in some of the "non Imported" categories dissapeared.

  5. #25

    Default

    Any idea about the above message anyone ?

    regards

  6. #26

    Default

    Not a great fan of bumping threads, but its been just over three weeks now, and i still cant get comments to display as mentioned 2 posts back.

    Show Replies on Separate Page is set to no, and all permissions are set to allow posting replies.

    Any ideas ?


    Update:

    Grrrr, what a numpty i am,

    Category permisions were set to moderation, how i missed that i will never know.
    Resolved
    Last edited by Magz; 09-08-2008 at 07:27 PM.

  7. #27
    Join Date
    Sep 2004
    Posts
    3

    Default

    I'm afraid I can't get this import script to work. I'm running vBulletin v3.7.3 Patch Level 1 and vBadvanced Dynamics v1.0.3. The script will allow be to select the forum to import from, but it the displays the following error:

    PHP Fatal error: Call to undefined function print_cat_select() in vba_dyna_import_vbposts.php on line 55

    Any ideas?

  8. #28
    Join Date
    Sep 2004
    Posts
    3

    Default

    Okay, I fixed my problem. A few functions needed to be prefixed with 'dyna_' before they would work. I've attached the updated script.

  9. #29
    Join Date
    Nov 2008
    Posts
    4

    Default

    each time i try to run the importer i get this msg
    Your vBa Dynamics attachments folder is not writable. Please make sure that your '/home/users/public_html/downloads/attach' folder on your server is chmod to 777. Once you have updated this you may refresh the page to resume the import.
    i noticed that its looking for the folder with the structure '/home/users/public_html/downloads/attach' but i dont have it that way..its setup as "/albumhunt.com/html/downloads/"

    and i have triple checked those folder to make sure they writable.

    btw vb ver 3.7.4 and the latest vb dyna

    help?

    EDIT: FIXED!!! simple settings needed to be changed in the dyna acp
    Last edited by albumhunt; 11-28-2008 at 12:49 PM.

  10. #30

    Default

    Hi,

    When I run the importer all I get is a blue screen (see attachment) - no way back to the admincp and no forums are imported.

    Am I doing something wrong?

    1) Created categories that match the forums that I want imported (not sure if this matters or not)

    2) Run the import script from the admincp

    3) Select the forums I want to import

    4) Press Continue

    5) Result = blue screen

    6) Update all counters etc.

    Still nothing. Did I miss something?

    Regards,
    Renada

  11. #31
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    There's not any reason I'm aware of that would cause a blue screen like that... If you would like to submit a support ticket via the Members' Area here and be sure to mention which forum's you would like to import then I'll be glad to take a look at things for you.

  12. #32

    Default

    Quote Originally Posted by Brian View Post
    There's not any reason I'm aware of that would cause a blue screen like that... If you would like to submit a support ticket via the Members' Area here and be sure to mention which forum's you would like to import then I'll be glad to take a look at things for you.
    Thanks Brian will do

  13. #33
    Join Date
    Mar 2009
    Posts
    13

    Default

    Quote Originally Posted by Renada View Post
    Hi,

    When I run the importer all I get is a blue screen (see attachment) - no way back to the admincp and no forums are imported.

    Regards,
    Renada
    I have this issue too with 3.8.2. I will scour error logs and report back.

    The error is: Fatal error: Call to undefined function print_cat_select() in /sites/mydellmini.com/http/forum/admincp/vba_dyna_import_vbposts.php on line 58

    I downloaded the version in the first post of this thread.
    Last edited by Dunhamzzz; 05-27-2009 at 11:40 AM.

  14. #34
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    Sorry about that. Looks like the attached file needed to be updated for use with the latest version. I've just made a couple of changes to the import file attached to the first post here, so if you'll download the file again and upload the updated version to your server, you should be able to go through with the import afterward.

  15. #35
    Join Date
    Mar 2009
    Posts
    13

    Default

    Ok this script does not work. It messed up the first time because the folder wasn't writable (although I'm pretty sure it was, how did it store my attachements earlier?)

    Upon trying to start again it hit a dupliciate key errors as the first try did not clear after itself. Now my only option is to manually go through the database and delete what was added with the import, thankfully I only tried to import one article into a database that only had 1 article in it before hand, its going to take a while but is doable none the less, anyone attempting this with any amount of articles / or no database knowledge should not try this.

    Personally I regret purchasing this script, its a premium paid for product that doesn't receive the level of support a premium product should. Hell, you didn't even run the original import script ONCE to test it as you'd have seen the blatant misnamed functions.

  16. #36
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    The script checks that your *Dynamics* attachment folder is writable, so that part has nothing to do with the your ability to upload attachments in vBulletin before.

    I'm not sure what else you're expecting as far as support, but we've answered any questions you've asked.

    The import certainly was tested and has been used by several people. Certain function names were changed in a recent release of vBa Dynamics though to avoid any possibility of conflicts with other software, which is why the import script had to be updated to include use the new function names.

  17. #37
    Join Date
    Mar 2009
    Posts
    13

    Default

    THe problem was is that the failed import took up all they primary keys that the script or some reason needs in the database, and with no clean up done by the script, made another import (which was inevitable due to the failed one earlier) impossible without manual database pruning

  18. #38
    Join Date
    Nov 2007
    Location
    Nashville, Tennessee
    Posts
    249

    Default

    Hey Brian!

    Is there a way to import vBa Dyna articles back into my base vB forums?

    Thanks!
    Jeff

  19. #39
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    Importing back to your forums is certainly posssible, but as far as I'm aware there have not been any import scripts posted.
    Frequently Asked Questions
    CMPS Users Manual

    For vBadvanced software assistance, please use the support forums.
    Unsolicted PMs, IMs, and email will not be responded to.
    If you have a non-software related question or problem with your account, please submit a support ticket.

  20. #40
    Join Date
    Apr 2009
    Posts
    18

    Default

    Just dosent seem to work for me in the first or second instance. Any Ideas?


    Database error in vBulletin 3.8.2:

    Invalid SQL:
    INSERT INTO adv_dyna_entries (entryid, title, catid, userid, username, dateline, views, posts, iconid, valid, open, sticky, showsignature, votenum, votetotal, ipaddress) VALUES (
    228,
    'Stillwater Supply Collars',
    7,
    '78',
    'StillwaterSupply',
    '1229203833',
    '384',
    '13',
    '0',
    '1',
    '1',
    '0',
    '0',
    '0',
    '0',
    '69.1.14.204'
    );

    MySQL Error : Duplicate entry '228' for key 1
    Error Number : 1062
    Request Date : Monday, August 24th 2009 @ 11:48:45 PM
    Error Date : Monday, August 24th 2009 @ 11:48:45 PM
    Script : http://www.doberman-chat.com/admincp....php?do=import
    Referrer : http://www.doberman-chat.com/admincp...o=submitforums
    IP Address : 24.180.141.176
    Username : VonDoom
    Classname : vB_Database_MySQLi
    MySQL Version : 5.0.58-log
    Last edited by VonDoom; 08-25-2009 at 02:04 AM.

Page 2 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. forum importer
    By Lionel in forum Feedback & Suggestions
    Replies: 5
    Last Post: 08-27-2007, 08:05 AM
  2. vBulletin Development Update: vBulletin 3.5
    By ManagerJosh in forum Chit Chat
    Replies: 58
    Last Post: 10-05-2005, 01:46 AM
  3. width of forums changed after module was enabled in forums
    By bringindaruckus in forum Troubleshooting / "How do I..." Questions
    Replies: 7
    Last Post: 06-03-2005, 05:45 PM
  4. vbulletin functions outside of forums directory
    By dionysis in forum Troubleshooting / "How do I..." Questions
    Replies: 1
    Last Post: 01-04-2005, 07:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •