Results 1 to 4 of 4

Thread: [RC2] Integration not saving page association settings

  1. #1
    Join Date
    Mar 2004
    Location
    A galaxy far, far away...
    Posts
    6,609

    Default [RC2] Integration not saving page association settings

    I have two CMPS page named "vBa Links" and "vBGallery" both configured as Module pages.

    I have "links_index" associated to the "vBa Links" page and "gallery_index" associated to the "vBGallery" page using the THIS_SCRIPT integration method.

    When I save the settings each association is correct during the "Select the CMPS page that you would like to integrate..." confirmation page has the correct associations.

    When I visit the vBa Links index page the modules on the "vBa Links" CMPS page are displaying the correct ones. I can't verify the gallery settings because integrating vBGallery using the THIS_SCRIPT method isn't working (still trying to figure that one out; others are having the same problem).

    The problem is that when I then go back into the CMPS integration settings page both "links_index" and "gallery_index" are showing as being associated to the "vBGallery" CMPS page.

    The other ticket is still open.

  2. #2
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default Re: [RC2] Integration not saving page association settings

    Looks like there's a small issue where (obviously) it's not selecting the correct page. If you'll open your includes/vba_cmps_adminfunctions.php file, look for this code:
    PHP Code:
            if (!$selectopts)
            {
                
    $selectopts print_integration_page_select($intpage'name'$vbphrase['remove'], $exclude);
            } 
    And replace with this:
    PHP Code:
            $selectopts print_integration_page_select($intpage'name'$vbphrase['remove'], $exclude); 
    Then that should take care of the problem.

  3. #3
    Join Date
    Mar 2004
    Location
    A galaxy far, far away...
    Posts
    6,609

    Default Re: [RC2] Integration not saving page association settings

    Quote Originally Posted by Brian View Post
    Looks like there's a small issue where (obviously) it's not selecting the correct page. If you'll open your includes/vba_cmps_adminfunctions.php file, look for this code:
    PHP Code:
            if (!$selectopts)
            {
                
    $selectopts print_integration_page_select($intpage'name'$vbphrase['remove'], $exclude);
            } 
    And replace with this:
    PHP Code:
            $selectopts print_integration_page_select($intpage'name'$vbphrase['remove'], $exclude); 
    Then that should take care of the problem.
    That seems to take care of it, thanks.

  4. #4

    Default Re: [RC2] Integration not saving page association settings

    This resolved my issue as well, Thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Integration settings within admincp
    By motowebmaster in forum Troubleshooting & Problems
    Replies: 3
    Last Post: 09-26-2007, 02:18 PM
  2. module settings not saving
    By WAR in forum Troubleshooting & Problems
    Replies: 4
    Last Post: 06-20-2007, 01:53 PM
  3. vba links 2.0 beta2 saving settings
    By jluerken in forum Bugs From 2.0 Beta 2
    Replies: 6
    Last Post: 10-18-2006, 12:57 AM
  4. Saving module collapse settings per user?
    By trana in forum Troubleshooting & Problems
    Replies: 4
    Last Post: 05-26-2006, 09:26 PM
  5. After saving changes, blank page occurs
    By brando in forum Troubleshooting & Problems
    Replies: 12
    Last Post: 08-21-2005, 06:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •