Results 1 to 12 of 12

Thread: How can I enable attachments with replies?

  1. #1
    Join Date
    Jun 2005
    Posts
    13

    Default How can I enable attachments with replies?

    I've tried searching the settings and can't find where I can enable attachments for REPLIES. I am using this as a recipes system and I'd like for people to use each recipes to be able to reply and attach an image, if they would like to.

  2. #2
    Join Date
    Jun 2005
    Posts
    13

    Default Re: How can I enable attachments with replies?

    Also, I don't know if this is possible but this would be SUPER awesome if it was When someone replies with an attachment, if the thumbnail could go in the FIRST post. It would be awesome to be able to show like the first 4 or 6 thumbails in the first post, then maybe hit a "more pictures" link to view more if there are more (so you don't have 50 thumbs if 50 people have made the recipe and upload a pic for it).

    I know this is kind of far fetched but I figured I'd at least ask/suggest for a possible future release maybe

    And I'd just like to say THANK YOU for this awesome software. This is absolutely exactly what I need and so worth the $50 for it. Thank you for all of your work on this.

  3. #3
    Join Date
    Jun 2005
    Posts
    13

    Default Re: How can I enable attachments with replies?

    I have one more question-

    Is there any way possible to add a "default" attachment for new entries that don't have one? Because when it shows on the main page, I'd like for all entries to have some sort of pic next to it, even if it's just something default that says "No Picture Yet" or something to that effect. Then when someone adds a pic, it could update to the picture uploaded instead of the default? I know that is probably asking for way too much

  4. #4
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default Re: How can I enable attachments with replies?

    Sorry, but currently there is not an option to allow attachments in replies.

    You should be able to add a default image for entries without one pretty easily. If you're using the expanded entrybit template, then you would want to look in your 'adv_dyna_entrybit_expanded' tempalate for this code:
    Code:
    					<if condition="$show['firstattachment']">
    						<if condition="$entry['hasthumb']">
    							<a href="attachment.php?$session[sessionurl]do=fullview&amp;attachmentid=$entry[attachmentid]"$target_blank><img src="$entry[thumburl]" alt="$entry[filename]" border="0" align="$stylevar[left]" style="padding-right: $stylevar[cellpadding]px; padding-bottom: $stylevar[cellpadding]px" /></a>
    						<else />
    							<div style="padding-bottom: $stylevar[cellpadding]px"><a href="attachment.php?$session[sessionurl]attachmentid=$entry[attachmentid]&amp;d=$entry[attachdateline]"$target_blank><img class="inlineimg" src="$stylevar[imgdir_attach]/$entry[extension].gif" alt="<phrase 1="$entry[extension]">$vbphrase[file_type_x]</phrase>" width="16" height="16" border="0" title="<phrase 1="$entry[extension]">$vbphrase[file_type_x]</phrase>" /></a> <a href="attachment.php?$session[sessionurl]attachmentid=$entry[attachmentid]&amp;d=$entry[attachdateline]">$entry[filename]</a></div>
    						</if>
    					</if>
    And replace with something like this:
    Code:
    					<if condition="$show['firstattachment']">
    						<if condition="$entry['hasthumb']">
    							<a href="attachment.php?$session[sessionurl]do=fullview&amp;attachmentid=$entry[attachmentid]"$target_blank><img src="$entry[thumburl]" alt="$entry[filename]" border="0" align="$stylevar[left]" style="padding-right: $stylevar[cellpadding]px; padding-bottom: $stylevar[cellpadding]px" /></a>
    						<else />
    							<div style="padding-bottom: $stylevar[cellpadding]px"><a href="attachment.php?$session[sessionurl]attachmentid=$entry[attachmentid]&amp;d=$entry[attachdateline]"$target_blank><img class="inlineimg" src="$stylevar[imgdir_attach]/$entry[extension].gif" alt="<phrase 1="$entry[extension]">$vbphrase[file_type_x]</phrase>" width="16" height="16" border="0" title="<phrase 1="$entry[extension]">$vbphrase[file_type_x]</phrase>" /></a> <a href="attachment.php?$session[sessionurl]attachmentid=$entry[attachmentid]&amp;d=$entry[attachdateline]">$entry[filename]</a></div>
    						</if>
    					<else />
    						<img src="path/to/default/image.ext" />
    					</if>
    If you're using the simple entrybit template, then you would want to look in your 'adv_dyna_entrybit_simple' for this code:
    Code:
    			<if condition="$show['firstattachment']">
    				<if condition="$entry['hasthumb'] AND $show['thumbs']">
    					<a href="attachment.php?$session[sessionurl]do=fullview&amp;attachmentid=$entry[attachmentid]"$target_blank><img src="$entry[thumburl]" alt="$entry[filename]" border="0" /></a>
    				<else />
    					<a href="attachment.php?$session[sessionurl]attachmentid=$entry[attachmentid]&amp;d=$entry[attachdateline]"$target_blank><img class="inlineimg" src="$stylevar[imgdir_attach]/$entry[extension].gif" alt="<phrase 1="$entry[extension]">$vbphrase[file_type_x]</phrase>" width="16" height="16" border="0" title="$entry[filename]" /></a>
    				</if>
    			<else />
    				&nbsp;
    			</if>
    And replace with something like this:
    Code:
    			<if condition="$show['firstattachment']">
    				<if condition="$entry['hasthumb'] AND $show['thumbs']">
    					<a href="attachment.php?$session[sessionurl]do=fullview&amp;attachmentid=$entry[attachmentid]"$target_blank><img src="$entry[thumburl]" alt="$entry[filename]" border="0" /></a>
    				<else />
    					<a href="attachment.php?$session[sessionurl]attachmentid=$entry[attachmentid]&amp;d=$entry[attachdateline]"$target_blank><img class="inlineimg" src="$stylevar[imgdir_attach]/$entry[extension].gif" alt="<phrase 1="$entry[extension]">$vbphrase[file_type_x]</phrase>" width="16" height="16" border="0" title="$entry[filename]" /></a>
    				</if>
    			<else />
    				<img src="path/to/default/image.ext" />
    			</if>

  5. #5
    Join Date
    Jun 2005
    Posts
    13

    Default Re: How can I enable attachments with replies?

    Thank you VERY much!

    I'm so sad about no attachments with replies Do you think there is any possibility for adding that in the future?

  6. #6
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default Re: How can I enable attachments with replies?

    We won't be able to work attachments with replies into the next version, but there's a good possibility that it will be included in the future.

  7. #7
    Join Date
    Jun 2005
    Posts
    13

    Default Re: How can I enable attachments with replies?

    Quote Originally Posted by Brian View Post
    We won't be able to work attachments with replies into the next version, but there's a good possibility that it will be included in the future.
    OK, thanks so much Brian. I appreciate your help

  8. #8
    Join Date
    Dec 2006
    Posts
    10

    Default

    Quote Originally Posted by Brian View Post
    We won't be able to work attachments with replies into the next version, but there's a good possibility that it will be included in the future.
    Hi Brian,

    It's been two years now... Any news on this feature yet?

    xopek

  9. #9
    Join Date
    Oct 2006
    Posts
    7

    Default

    bit more than ANOTHER two years - has this been done?
    Or is it on the list?
    I bought Dynamics for a purpose that HAS to have attachments on replies. It wasn't clear to me that it did not. I just saw "attachments" on the list of features and assumed this was not restricted.

    So, any news please?

    I have sent private message about a custom job and this would be part of it.

  10. #10
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    I'm sorry, but the ability to add attachments to replies has not been added yet. It may be added in the future, but I can't say when that might be at this time.
    Frequently Asked Questions
    CMPS Users Manual

    For vBadvanced software assistance, please use the support forums.
    Unsolicted PMs, IMs, and email will not be responded to.
    If you have a non-software related question or problem with your account, please submit a support ticket.

  11. #11
    Join Date
    Dec 2006
    Posts
    10

    Default

    Hi Brian,

    Any news on this please? I'm sure many would agree, it's a very useful feature - and I had to implement the hack to allow it to work - but it's difficult to support it in this way and I'd very much like to have it as a part of native code!

    Denis

  12. #12
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    Sorry, but the status has not changed.
    Frequently Asked Questions
    CMPS Users Manual

    For vBadvanced software assistance, please use the support forums.
    Unsolicted PMs, IMs, and email will not be responded to.
    If you have a non-software related question or problem with your account, please submit a support ticket.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 08-19-2007, 01:31 PM
  2. HOW DO I: add file attachments to Replies?
    By ataraxia in forum "How Do I..." Questions
    Replies: 2
    Last Post: 12-04-2004, 02:29 PM
  3. enable
    By Zachery in forum Site Feedback & Updates
    Replies: 0
    Last Post: 01-27-2004, 03:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •