Results 1 to 4 of 4

Thread: Small problem with multiple poll modules.

  1. #1
    Join Date
    Jan 2007
    Posts
    209

    Default Small problem with multiple poll modules.

    Hi,

    I have used the admincp to "copy" the current poll module 8 times so there are 9 separate poll modules (each one using a separate corresponding forum). Everything seems to work, but there is a small issue with the poll results. After voting on a poll, the option you have voted for is italicized in the poll results. With multiple polls on the page, every poll after the first one has the worng options italicized.

    So if I voted for the first option in Poll 1, and the second option in Poll 2, the results for Poll 2 have both the first and second options italicized. If i voted for the fifth option in Poll 3 the 1st 2nd and 5th option are all italicized.

    I hope that made sense.

    Cheers,
    Ian

  2. #2
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default Re: Small problem with multiple poll modules.

    Thank you for pointing this out. If you will look in your modules/currentpoll.php file for this line:
    PHP Code:
    $uservote = array(); 
    Remove it from there, and paste it just above this line instead:
    PHP Code:
    if (!$mods['nodisplay']) 
    And that should take care of the issue.

  3. #3
    Join Date
    Jan 2007
    Posts
    209

    Default Re: Small problem with multiple poll modules.

    Thanks Brian.

    PS. While I am editing the file, do you think its a good idea to make this change?

    http://www.vbadvanced.com/forum/showthread.php?t=25624

  4. #4
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default Re: Small problem with multiple poll modules.

    You would also need to run this query if you do.
    Code:
    ALTER TABLE `poll` ADD INDEX ( `dateline` )

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Multiple polls in latest poll module
    By redraider in forum Module & Modification Discussion & Requests
    Replies: 3
    Last Post: 05-16-2007, 02:38 PM
  2. poll problem ... no votes added to the poll
    By fly2hi in forum Troubleshooting & Problems
    Replies: 3
    Last Post: 12-11-2006, 05:48 AM
  3. Problem with poll modules
    By Lordek in forum "How Do I..." Questions
    Replies: 7
    Last Post: 04-06-2006, 12:47 AM
  4. Replies: 1
    Last Post: 07-24-2005, 11:02 PM
  5. Small Problem adding modules to index page
    By anarchystar in forum Troubleshooting / "How do I..." Questions
    Replies: 9
    Last Post: 05-28-2005, 12:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •