Results 1 to 7 of 7

Thread: newreply.php possible issue

  1. #1
    Join Date
    Jul 2004
    Location
    Nagano, Japan
    Posts
    17

    Default newreply.php possible issue

    Hi there,

    I just upgraded to the latest beta2 version and am getting the following database error when replying to a link. The installation seemed to go well and everything looks updated so I'm not sure where to look here. The newreply.php is the latest uploaded from the update.

    http://www.ricoche.net/links/

    Thanks! - Jim

    Code:
    Database error in vBulletin 3.7.0:
    
    Invalid SQL:
    
    UPDATE adv_links_categories SET
    postcount = postcount + 1
    WHERE catid IN();
    
    MySQL Error   : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 3
    Error Number  : 1064
    Request Date  : Monday, June 2nd 2008 @ 09:18:08 PM
    Error Date    : Monday, June 2nd 2008 @ 09:18:08 PM
    Script        : http://www.ricoche.net/links/newreply.php
    Referrer      : http://www.ricoche.net/links/newreply.php?l=2
    Classname     : vB_Database
    MySQL Version : 5.0.51a-community
    Last edited by ricoche; 06-02-2008 at 10:46 PM.

  2. #2
    Join Date
    Jul 2004
    Location
    Nagano, Japan
    Posts
    17

    Default Re: newreply.php possible issue

    I should add that when I reply to a link it actually gets entered into the database, but doesn't seem to get pulled or something along those lines.

    When I physically delete the reply, I get the following error.

    Code:
    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /home/ricochen/public_html/links/moderate.php on line 2060
    
    Warning: Cannot modify header information - headers already sent by (output started at [path]/includes/class_core.php:3237) in /home/ricochen/public_html/links/moderate.php on line 2072

  3. #3
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default Re: newreply.php possible issue

    Thanks for pointing this out. I've updated the download package here to include the fix, so if you will download the files from here again and replace your links/addlink.php file with the updated version, that should take care of the issue.

  4. #4
    Join Date
    Jul 2004
    Location
    Nagano, Japan
    Posts
    17

    Default Re: newreply.php possible issue

    Splendid! Thanks Brian.

    Jim

  5. #5
    Join Date
    Jun 2008
    Location
    Ottawa
    Posts
    38

    Default Re: newreply.php possible issue

    I redownloaded the package and I'm still getting an error that I was mentionning here.

    TriMe

  6. #6
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default Re: newreply.php possible issue

    Try deleting the links/moderate.php file from your server and then re-upload the one that you just downloaded. If that does not help, please submit a support ticket via the Members' Area here and I'll take a look at things for you.

  7. #7
    Join Date
    Jun 2008
    Location
    Ottawa
    Posts
    38

    Default Re: newreply.php possible issue

    Yes I tried what you suggested, still get the error.

    Ill submit a ticket now,

    Thanks Brian

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Another issue
    By dcuellar in forum Troubleshooting & Problems
    Replies: 4
    Last Post: 03-14-2008, 10:13 AM
  2. Still another Nav issue ... sorry
    By Jmistrot in forum Troubleshooting & Problems
    Replies: 7
    Last Post: 04-26-2007, 11:20 AM
  3. Side modules on SHOWTHREAD, newreply, etc ?
    By mindbuster in forum Troubleshooting & Problems
    Replies: 17
    Last Post: 11-03-2006, 07:38 PM
  4. New Install~ Screwed up newreply.php
    By Susie_in_Texas in forum Troubleshooting & Problems
    Replies: 3
    Last Post: 02-09-2006, 07:57 PM
  5. how do i fix my issue? i cant see anything
    By lowandloudinc in forum Troubleshooting / "How do I..." Questions
    Replies: 3
    Last Post: 02-15-2005, 10:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •