Results 1 to 9 of 9

Thread: Error During Install.

  1. #1
    Join Date
    Feb 2008
    Posts
    11

    Default Error During Install.

    I keep getting an error. I have uninstalled and re-installed. Re-downloaded and so forth. Here's the error.

    Code:
    Database error in vBulletin 3.7.1:
    
    Invalid SQL:
    
    		INSERT INTO setting
    			(varname, grouptitle, value, defaultvalue, optioncode, displayorder, advanced, volatile, datatype, product, validationcode, blacklist)
    		VALUES (
    			'vba_links_homeurl',
    			'version',
    			'',
    			'',
    			'',
    			'1000',
    			'0',
    			'1',
    			'free',
    			'adv_links',
    			'',
    			'0'
    		), (
    			'vba_links_title',
    			'version',
    			'',
    			'',
    			'',
    			'1010',
    			'0',
    			'1',
    			'free',
    			'adv_links',
    			'',
    			'0'
    		), (
    			'vba_links_addnavbar',
    			'version',
    			'',
    			'',
    			'',
    			'1010',
    			'0',
    			'1',
    			'free',
    			'adv_links',
    			'',
    			'0'
    		), (
    			'vba_links_addnavsearch',
    			'version',
    			'',
    			'',
    			'',
    			'1010',
    			'0',
    			'1',
    			'free',
    			'adv_links',
    			'',
    			'0'
    	);
    
    MySQL Error   : Duplicate entry 'vba_links_homeurl' for key 1
    Error Number  : 1062
    Request Date  : Tuesday, September 16th 2008 @ 10:47:39 AM
    Error Date    : Tuesday, September 16th 2008 @ 10:47:43 AM
    Script        : http://www.theburningreel.com/forums...ks_install.php
    Referrer      : http://www.theburningreel.com/forums...ks_install.php
    IP Address    : 71.2.232.246
    Username      : FairWeather
    Classname     : vB_Database
    MySQL Version : 5.0.67-log

  2. #2
    Join Date
    Feb 2008
    Posts
    11

    Default

    and when I load my page www.*****.com/links I get this error

    Code:
    Warning: Invalid argument supplied for foreach() in [path]/includes/vba_links_class.php on line 325
    
    Warning: Invalid argument supplied for foreach() in [path]/includes/vba_links_functions_cats.php on line 435
    
    Warning: Invalid argument supplied for foreach() in [path]/includes/vba_links_functions_cats.php on line 43

  3. #3
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    Thank you for pointing this out. Looks like the new vB settings that were added in 3.0.0 were not being deleted when uninstalling. I've just updated the forum/admincp/vbalinks_install.php file here correct this, so if you will download the files from here again and update that one on your server, you should then be able to use the Un-install option to remove those and then re-install.

  4. #4
    Join Date
    Feb 2008
    Posts
    11

    Default

    Brian,

    I know have it installed right I think, but I have two issues..

    1. I'm getting an error message at the top of the screen on only the main page.
    2. The border on my page is getting cut off also, only on the main page (please see where arroow is).

    Any assistance would be appreciated.

    Here's a picture to help show you.

  5. #5
    Join Date
    Feb 2008
    Posts
    11

    Default

    No Worries Brian..

    I got it!!! Thanks again!!!

  6. #6
    Join Date
    Nov 2007
    Posts
    87

    Default

    What did you do to fix this error? I'm getting the same thing.

    ------------------------
    Quote Originally Posted by ECMatt90 View Post
    No Worries Brian..

    I got it!!! Thanks again!!!
    -------------------------

    Update: Brian wrote in another thread, "Sounds like you did not fully re-install. I would suggest using the vbalinks_install.php file to un-install and then re-install. If you still have the same error afterwards please submit a support ticket via the Members' Area here."

    This fixed it.

  7. #7

    Default

    We just installed the latest code. www.unix.com/links

    It was working fine, then it stopped working with these errors:

    Getting these errors:

    Warning: Invalid argument supplied for foreach() in [path]/includes/vba_links_class.php on line 325

    Warning: Invalid argument supplied for foreach() in [path]/includes/vba_links_functions_cats.php on line 435

    Warning: Invalid argument supplied for foreach() in [path]/includes/vba_links_functions_cats.php on line 43

    Fatal error: Cannot use string offset as an array in /website/www/includes/vba_links_functions_cats.php on line 86
    And CP errors in Main Index Page Options:

    Warning: Invalid argument supplied for foreach() in [path]/includes/vba_links_adminfunctions.php on line 419
    Errors come and go .....
    Last edited by lostcode; 01-04-2009 at 02:26 PM.

  8. #8
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    Sounds like something may have become corrupted with the category cache. Try saving one of your categories through the Admin CP to update the cache and see if that takes care of the problem.

  9. #9

    Default

    Quote Originally Posted by Brian View Post
    Sounds like something may have become corrupted with the category cache. Try saving one of your categories through the Admin CP to update the cache and see if that takes care of the problem.
    The problem seems to have been from our vBoptimize plugin. To stop the intermittent errors we have turned off datastore cache. Hopefully, this will stop the errors.

    From the vBoptimize datastore cache settings description:

    Currently, vBulletin has the ability for modification authors to allow datastore items to load at the start-up of vBulletin, this is useful for modification authors who use custom datastore data in existing areas of vBulletin. This addition however can cost users with any of these modifications an additional query on pages.

    If you turn this setting to Yes, vB Optimise will take the custom datastore data and ensure it uses the proper datastore method that you have chosen to use in your vBulletin configuration, eliminating the extra query used on your pages. Note that if you have not set up your vBulletin installation to use any special means of vBulletin datastore (Filecache, XCache, etc..), or if you have no modifications that trigger this extra query then this setting will have no impact on your forums performance.
    www.unix.com/links

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. sql error on install
    By Ramses in forum Troubleshooting & Problems
    Replies: 6
    Last Post: 06-12-2008, 10:58 AM
  2. error after install
    By cartman in forum Troubleshooting & Problems
    Replies: 6
    Last Post: 08-24-2007, 12:35 PM
  3. Get error after install.
    By Sooner95 in forum Troubleshooting & Problems
    Replies: 1
    Last Post: 12-08-2005, 02:48 PM
  4. Error after install.
    By spaghie in forum Troubleshooting & Problems
    Replies: 6
    Last Post: 10-19-2005, 08:14 PM
  5. Error doing install
    By helpinghand in forum Troubleshooting / "How do I..." Questions
    Replies: 6
    Last Post: 05-23-2005, 09:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •