Results 1 to 5 of 5

Thread: Database error submitting new user category

  1. #1
    Join Date
    Jul 2005
    Posts
    120

    Default Database error submitting new user category

    While submitting a new category within my own categories I noticed a blank entry space inbetween 'Parent Category' and 'Category Style'. If I try to enter some text (which does not have any headline/title) I first get this error:

    Fatal error: Unsupported operand types in /home/xxxx/public_html/links/managecats.php on line 101

    If I then try to click whatever link navbar link:

    Fatal error: Unsupported operand types in /home/xxxx/public_html/forum/includes/vba_links_functions.php on line 212

    It seems that the empty space is not suppose to be there...?

  2. #2
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    Strange... Try editing one of your categories through the Admin CP and save it so that the cache will be updated and see if that helps.

  3. #3
    Join Date
    Jul 2005
    Posts
    120

    Default

    I think I found the error:

    Modify settings -> User Category Options -> New Category Display Order

    If you here choose -> Users Choice

    Then it will give the extra box inbetween 'Parent Category' and 'Category Style' after pressing "submit new category".

    I can remove the error by choosing, 'Top' or 'Bottom' in stead....

  4. #4
    Join Date
    Jul 2005
    Posts
    120

    Default

    By the way. This is still unsolved... (except there is no longer any error message). Top or Bottom works. 'Users choice' doesn't - at least not for me...

  5. #5
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    Thank you for pointing that out. The issue has been corrected in the dev files and the fix will be included with the next release.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Search by user name database error.
    By attroll in forum Bugs From 3.0 Beta 2
    Replies: 3
    Last Post: 07-10-2008, 06:24 PM
  2. Database error on Delete Category
    By RaceJunkie in forum Troubleshooting & Problems
    Replies: 4
    Last Post: 11-28-2007, 11:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •