Results 1 to 10 of 10

Thread: CMPS Online module

  1. #1
    Junior Member
    Join Date
    Jun 2007
    Posts
    7

    Question CMPS Online module

    Hi There

    Anyone had this issue?

    We use online module to the left of our forum, it seems to work fine in all browsers apart from IE

    Whats the significance of removing {vb:stylevar dirmark} would be in the adv_portal_onlineusers template.

    This seems to fix the issue, any advise please?

    We using vB 4.1.2 and latest CMPS

  2. #2
    Administrator Brian's Avatar
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,460

    Default

    It looks like vB decided to change their "commalist" CSS in vB 4.1.2 for some reason. You should be able to resolve the issue by replacing the contents of your 'adv_portal_online' template with the following code:
    Code:
    <div class="blocksubhead">{vb:rawphrase x_members_and_y_guests, {vb:raw numberregistered}, {vb:raw numberguest}}</div>
    <div class="blockrow vba_spacer">
    	<vb:if condition="$activeusers">
    		<vb:each from="activeusers" value="loggedin">
    			<a class="username" href="{vb:link member, {vb:raw loggedin}}">{vb:raw loggedin.musername}</a>{vb:raw loggedin.invisiblemark}{vb:raw loggedin.buddymark},
    		</vb:each>
    	<vb:else />
    		{vb:rawphrase no_x_online, {vb:rawphrase members}}
    	</vb:if>
    </div>
    <div class="blockrow">{vb:rawphrase most_users_ever_online_was_x_y_at_z, {vb:raw recordusers}, {vb:raw recorddate}, {vb:raw recordtime}}</div>
    Last edited by Brian; 03-16-2011 at 01:39 PM.
    Frequently Asked Questions
    CMPS Users Manual

    For vBadvanced software assistance, please use the support forums.
    Unsolicted PMs, IMs, and email will not be responded to.
    If you have a non-software related question or problem with your account, please submit a support ticket.

  3. #3
    Junior Member
    Join Date
    Jan 2011
    Posts
    8

    Default

    Sorry If that does not still.
    Attached Images Attached Images

  4. #4
    Junior Member
    Join Date
    Feb 2011
    Posts
    3

    Default

    Brian I tested the code change above as suggested and it hasn't resolved the problem. I work with Sheriff116 on the forum suffering the issue.

    Any help or other suggestions would be really appreciated. The only fix I have found to date was the one suggested in the original post.

  5. #5
    Administrator Brian's Avatar
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,460

    Default

    It looks like the "{vb:stylevar dirmark}" code may be causing some issues too. Try removing that code from your 'adv_portal_onlineusers' template and see if that solves the problem.
    Frequently Asked Questions
    CMPS Users Manual

    For vBadvanced software assistance, please use the support forums.
    Unsolicted PMs, IMs, and email will not be responded to.
    If you have a non-software related question or problem with your account, please submit a support ticket.

  6. #6
    Junior Member
    Join Date
    Jan 2011
    Posts
    8

    Default

    Code:
    <div class="blocksubhead">{vb:rawphrase x_members_and_y_guests, {vb:raw numberregistered}, {vb:raw numberguest}}</div>
    <div class="blockrow vba_spacer">
    	<vb:if condition="$activeusers">
    		<vb:each from="activeusers" value="loggedin">
    	   <a class="username" href="{vb:link member, {vb:raw loggedin}}">{vb:raw loggedin.musername}</a>{vb:raw loggedin.invisiblemark}{vb:raw loggedin.buddymark},
    		</vb:each>
    	<vb:else />
    		{vb:rawphrase no_x_online, {vb:rawphrase members}}
    	</vb:if>
    </div>
    <div class="blockrow">{vb:rawphrase most_users_ever_online_was_x_y_at_z, {vb:raw recordusers}, {vb:raw recorddate}, {vb:raw recordtime}}</div>
    Thank you! With this code, it also works in ie8.

  7. #7
    Junior Member
    Join Date
    Feb 2011
    Posts
    3

    Default

    Quote Originally Posted by Brian View Post
    It looks like the "{vb:stylevar dirmark}" code may be causing some issues too. Try removing that code from your 'adv_portal_onlineusers' template and see if that solves the problem.
    Thanks Brian for confirming this piece of code could be removed. I have done so and the online users module is displaying as expected in IE again

    Once again thanks for your help and keep up the good work with CMPS

  8. #8
    Member
    Join Date
    Nov 2007
    Location
    Hobart, Tasmania, Australia
    Posts
    30

    Default

    vB4.1.3 here and we had to remove "{vb:stylevar dirmark}" to make it work
    Last edited by ricktas; 04-19-2011 at 11:29 PM.
    AusPhotography - Australia's Premier Photographic Forum
    www.ausphotography.net.au is a photography forum where members share their photography, photo editing skills and techniques. We run regular photographic competitions
    Rick (site owner) and Kym (site tech) using this account
    Please vote for IPv6 support

    Home of the AP fully comprehensive vb4 photographic competition management solution

  9. #9
    Junior Member
    Join Date
    Jan 2010
    Posts
    25

    Default

    Thanks removing {vb:stylevar dirmark} from the template worked great.

  10. #10
    Junior Member
    Join Date
    Jun 2007
    Posts
    10

    Default

    Recent upgrade from 4.1.5 to 4.1.9 broke this module for me and the code examples do not solve it.

    I will proceed to upgrade vBadvanced to the lates version to see what happens. I'll update this thread with my results.

    *edit* The upgrade worked. Thanks.
    Last edited by JesterP; 12-28-2011 at 07:14 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. online users module - link to online.php
    By pmkb in forum Feedback & Suggestions
    Replies: 0
    Last Post: 11-22-2009, 11:26 AM
  2. cmps online-module disappears sometimes with dyna
    By Moonz0r in forum Troubleshooting & Problems
    Replies: 1
    Last Post: 02-18-2008, 01:42 PM
  3. Where is CMPS online documentation?
    By cnsanford in forum "How Do I..." Questions
    Replies: 2
    Last Post: 05-02-2007, 11:57 AM
  4. CMPS 2.0.0 - Who's Online Bug
    By ConqSoft in forum Troubleshooting & Problems
    Replies: 9
    Last Post: 12-01-2005, 05:19 PM
  5. Who's Online on vBA CMPS
    By KnightDaemon in forum Add-On Modules & Modifications
    Replies: 0
    Last Post: 11-07-2004, 01:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •