Results 1 to 2 of 2

Thread: Lightbox images not loading for guests when human verification is enabled

  1. #1
    Join Date
    Oct 2004
    Posts
    359

    Default Lightbox images not loading for guests when human verification is enabled

    when enable:
    Enable Lightbox For Attachments

    and enable:
    Enable Human Verification for Guests
    for Download Attachment

    geust when click the thmbnail in the showenry page will get 404 error or javascript error that say the id of image is not correct or missing something like that

    is this normal or should he get error permission ?

  2. #2
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    The human verification setting is intended more to help protect file downloads and not images, though they shouldn't receive a javascript error. I've just updated the dynamics/attachment.php file to make sure the human verification is disabled for images with thumbnails if the lightbox is enabled. If you will download the files again and update that file on your server then that should take care of the error and allow the image to be loaded.
    Or if you would rather apply the fix manually, just look in your dynamics/attachment.php file for this line:
    PHP Code:
    if ($_POST['do'] != 'humanverify' AND !$vbulletin->GPC['thumb'] AND in_array('downloadattach'$vba_options['dyna_imageverify']) AND !$vbulletin->userinfo['userid']) 
    And replace with this:
    PHP Code:
    if ($_POST['do'] != 'humanverify' AND !$vbulletin->GPC['thumb'] AND !$attachment['hasthumb'] AND in_array('downloadattach'$vba_options['dyna_imageverify']) AND !$vbulletin->userinfo['userid']) 
    Frequently Asked Questions
    CMPS Users Manual

    For vBadvanced software assistance, please use the support forums.
    Unsolicted PMs, IMs, and email will not be responded to.
    If you have a non-software related question or problem with your account, please submit a support ticket.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Lightbox For Images?
    By angeljs in forum Module & Modification Discussion & Requests
    Replies: 3
    Last Post: 05-11-2011, 04:59 AM
  2. Inline attached images not using lightbox
    By djxcee in forum Troubleshooting & Problems
    Replies: 14
    Last Post: 08-04-2010, 01:22 PM
  3. Lightbox not loading image
    By djxcee in forum Troubleshooting & Problems
    Replies: 13
    Last Post: 05-25-2009, 05:30 PM
  4. News images & Lightbox
    By Tom M in forum Troubleshooting & Problems
    Replies: 7
    Last Post: 02-28-2009, 10:39 AM
  5. Images fine EXCEPT those to the verification - GD
    By floydian1 in forum Troubleshooting & Problems
    Replies: 1
    Last Post: 06-04-2006, 11:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •