Results 1 to 4 of 4

Thread: strange issues with navbar dyna

  1. #1
    Join Date
    Oct 2004
    Posts
    359

    Default strange issues with navbar dyna

    hello i face 2 issues wuth navbar dyna:

    1.for new dyna that i install and some old , the post links for whatsnew?:
    for days it will give link to:
    myvbadyna.com/whatsnew/entries/3/
    for 3 days post as example
    it should give :
    myvbadyna.com/whatsnew/post/3/


    2.my old dyna which some of them has not added any new entries or posts since month
    it will give :
    array text
    and even i added enteries or post , this issue will disappear
    i try to rebuilt settings and also i disable many products but still this issue appear and this appear only for old instances of dyna which has old entries and even i add new it will not disappear , also id does not show days for what is new?

    in attachement i will show example for this second issue:

  2. #2
    Join Date
    Oct 2004
    Posts
    359

  3. #3
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    Thank you for pointing this out. If you will look in your 'adv_dyna_navbar' template for this code:
    Code:
    						<vb:if condition="$vba_options['dyna_allowreplies']">
    							<li class="blocksubhead">{vb:rawphrase vba_new_posts}</li>
    							<li{vb:raw show.vba_li_menu_class}><a href="{vb:raw newpostslink}{vb:raw session.sessionurl_q}">{vb:rawphrase since_your_last_visit}</a></li>
    							<vb:each from="newentrynavbits" key="dayno" value="whatsnewlink">
    								<li{vb:raw show.vba_li_menu_class}><a href="{vb:raw whatsnewlink}" rel="nofollow">{vb:rawphrase last_x_days, {vb:raw dayno}}</a></li>
    							</vb:each>
    						</vb:if>
    And replace it with this:
    Code:
    						<vb:if condition="$vba_options['dyna_allowreplies']">
    							<li class="blocksubhead">{vb:rawphrase vba_new_posts}</li>
    							<li{vb:raw show.vba_li_menu_class}><a href="{vb:raw newpostslink}{vb:raw session.sessionurl_q}">{vb:rawphrase since_your_last_visit}</a></li>
    							<vb:each from="newpostnavbits" key="dayno" value="whatsnewlink">
    								<li{vb:raw show.vba_li_menu_class}><a href="{vb:raw whatsnewlink}" rel="nofollow">{vb:rawphrase last_x_days, {vb:raw dayno}}</a></li>
    							</vb:each>
    						</vb:if>
    Then that should take care of the problem.
    Frequently Asked Questions
    CMPS Users Manual

    For vBadvanced software assistance, please use the support forums.
    Unsolicted PMs, IMs, and email will not be responded to.
    If you have a non-software related question or problem with your account, please submit a support ticket.

  4. #4
    Join Date
    Oct 2004
    Posts
    359

    Default

    thanks fixed
    Last edited by deathemperor; 04-06-2011 at 05:57 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Dyna navbar missing
    By neverstop in forum Troubleshooting & Problems
    Replies: 0
    Last Post: 11-26-2010, 01:10 PM
  2. issues in dyna
    By deathemperor in forum Troubleshooting & Problems
    Replies: 3
    Last Post: 04-13-2009, 06:58 PM
  3. Strange login and cookie issues
    By BonsaiNut in forum Troubleshooting & Problems
    Replies: 12
    Last Post: 11-02-2007, 11:07 AM
  4. Strange double slash issues
    By RhinoForums.net in forum Troubleshooting & Problems
    Replies: 2
    Last Post: 06-06-2007, 12:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •