Results 1 to 10 of 10

Thread: Invalid Redirect URL Error on All Links

  1. #1
    Junior Member
    Join Date
    Aug 2008
    Location
    New England
    Posts
    22

    Exclamation Invalid Redirect URL Error on All Links

    I am running Links Directory v3.2.0 with vBulletin 3.8.7 Patch Level 2. Recently I noticed that all links result in this vBulletin error (for example):

    Invalid Redirect URL (http://www.melvinvillagemarina.com)
    I installed the latest vBulletin 3.8.7 PL2 update a few weeks ago and that may have been when this problem started. I can't be sure.

    Nothing has changed in my Links Directory installation in a long time so I'm thinking the 3.8.7 PL2 update broke it.

    Can anyone suggest a way to fix this?
    Last edited by Don Z.; 07-25-2011 at 09:41 AM. Reason: fixed quote

  2. #2

  3. #3
    Junior Member
    Join Date
    Aug 2008
    Location
    New England
    Posts
    22

    Default

    Thanks, that did fix it. It looks like the 3.8.7 PL2 update broke it. :-(

  4. #4
    Senior Member Chimpie's Avatar
    Join Date
    May 2008
    Location
    Sarasota, Florida
    Posts
    302

    Default

    Yep, that does it. I don't know if it's the best option, but it worked.

    Quote Originally Posted by Don Z. View Post
    Thanks, that did fix it. It looks like the 3.8.7 PL2 update broke it. :-(
    Brian, will us 3.8.x users be getting a proper fix?

    Thanks!
    CHIMPIE | SKYWARN

    "I have found Chimpie to be very professional, knowledgeable, prompt, and reasonably priced."
    "I would not hesitate to utilize his services again in the future, and I highly recommend him."

  5. #5
    Junior Member
    Join Date
    Oct 2005
    Posts
    18

    Default

    The same issue here.

    Any help to offer without changing the code in the functions.php of vbulletin?

    Thanks!

    Quote Originally Posted by Chimpie View Post



    Brian, will us 3.8.x users be getting a proper fix?

    Thanks!
    Last edited by klaush; 08-15-2011 at 10:46 AM.

  6. #6
    Administrator Brian's Avatar
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,434

    Default

    That's weird that vB decided to add a way around the redirect in the function for vB4, but not vB3 for some reason. Either way, this can be corrected by looking in the links/showlink.php file for this code:
    PHP Code:
        $vbulletin->url $vba_links->_link['linkurl'];
        eval(
    print_standard_redirect('adv_links_transferring'truefalse, -1true)); 
    And replacing it with this:
    PHP Code:
        exec_header_redirect($vba_links->_link['linkurl']); 
    Frequently Asked Questions
    CMPS Users Manual

    For vBadvanced software assistance, please use the support forums.
    Unsolicted PMs, IMs, and email will not be responded to.
    If you have a non-software related question or problem with your account, please submit a support ticket.

  7. #7
    Junior Member
    Join Date
    Oct 2005
    Posts
    18

    Default

    Thanks Brian; that did the trick!

    Greetings

    Klaus

  8. #8

    Default

    Thanks for this.
    Shawn

  9. #9
    Member
    Join Date
    May 2005
    Location
    PhillyaDelphia
    Posts
    41

    Default

    thanks for the update fix
    Nextel phone modding and other software programs at your service visit at: Puerto Technology Central



  10. #10
    Member
    Join Date
    Jul 2007
    Location
    London UK
    Posts
    30

    Smile

    Quote Originally Posted by Brian View Post
    That's weird that vB decided to add a way around the redirect in the function for vB4, but not vB3 for some reason. Either way, this can be corrected by looking in the links/showlink.php file for this code:
    PHP Code:
        $vbulletin->url $vba_links->_link['linkurl'];
        eval(
    print_standard_redirect('adv_links_transferring'truefalse, -1true)); 
    And replacing it with this:
    PHP Code:
        exec_header_redirect($vba_links->_link['linkurl']); 
    Sorry this thread is a little old - but this fix was applied VB4.2 and solved the problem - thanks Brian.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Invalid SQL Error Message when Adding Links
    By Mondi in forum Troubleshooting & Problems
    Replies: 1
    Last Post: 06-11-2010, 12:17 PM
  2. Redirect links
    By ascott in forum Troubleshooting & Problems
    Replies: 3
    Last Post: 07-15-2009, 01:46 PM
  3. do not redirect links !
    By rapics in forum "How Do I..." Questions
    Replies: 1
    Last Post: 05-11-2009, 09:55 AM
  4. redirect error ?
    By parrotfo in forum Troubleshooting & Problems
    Replies: 1
    Last Post: 01-30-2009, 10:37 AM
  5. Redirect links not working?
    By GameOfThrones in forum Troubleshooting & Problems
    Replies: 1
    Last Post: 09-12-2008, 10:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •