Page 1 of 3 123 LastLast
Results 1 to 20 of 57

Thread: Sub-Nav bar not showing on homepage

  1. #1
    Join Date
    Aug 2010
    Posts
    19

    Default Sub-Nav bar not showing on homepage

    Hello all,

    As the title states my sub nav bar is not showing, no text or link available...

    Website - http://fazedops.com/index.php

    Notice when you click on the forums they appear and operate fine? any ideas..

    many thanks

  2. #2
    Join Date
    Jan 2008
    Location
    Atlanta, GA
    Posts
    444

    Default

    ok.. when on the CMPS pages, the SubNav only shows links for SubPages for the page you are viewing. It does not display the Forum SubNav. So I would say it is working as intended.

  3. #3

    Default

    OK, is there a way to add the links to the CMPS page?

  4. #4
    Join Date
    Aug 2010
    Posts
    19

    Default

    Thanks all it works fine.

    DFORMS what type of link? Nav bar or block...

  5. #5

    Default

    The 'Forum Subnav' containing the following links:

    -New Posts
    -Private Messages
    -FAQ
    -Calendar
    -Community
    -Forum Actions
    -Quick Links

    Hers is an image of the area where I would like the 'Forum Subnav' to be displayed:

    I'm also missing the Navbar bottom border identified in the image with the thin red line.

    Thank you!

  6. #6
    Join Date
    Jan 2008
    Location
    Atlanta, GA
    Posts
    444

  7. #7

    Default

    No solution found in the thread you posted : s

  8. #8
    Join Date
    Jan 2008
    Location
    Atlanta, GA
    Posts
    444

    Default

    Quote Originally Posted by DFORMS View Post
    No solution found in the thread you posted : s
    The solution is in this post - http://www.vbadvanced.com/forum/show...8&postcount=10

    You have to tweak it to fit your forums/VB Version though

  9. #9

    Default

    OK, I don't really know what I have to tweak to make it fit on a default style? When I use the code provided without trying to mod it it gives me this error:

    The following error occurred when attempting to evaluate this template:

    Parse error: syntax error, unexpected '.' in /mounted-storage/home127/sub008/sc75656-HUSF/quebecod.com/forum/includes/adminfunctions_template.php(5217) : eval()'d code on line 144

    This is likely caused by a malformed conditional statement. It is highly recommended that you fix this error before continuing, but you may continue as-is if you wish.


    What exactly do I have to modify in the code? Is there not a standard copy/paste version that will work?

    Thank you Dragonsys!

  10. #10
    Join Date
    Jan 2008
    Location
    Atlanta, GA
    Posts
    444

    Default

    Quote Originally Posted by DFORMS View Post
    Is there not a standard copy/paste version that will work?

    Thank you Dragonsys!
    This is what my code looks like for the Default Style in vB v 4.1.4

    Code:
    			<li>
    				<ul class="floatcontainer">
    					{vb:raw template_hook.navbar_start}
    					<vb:if condition="$show['searchbuttons']">
    						<vb:if condition="$show['member']">
    						<li><a href="search.php?{vb:raw session.sessionurl}do=getnew&amp;contenttype=vBForum_Post">{vb:rawphrase new_posts_nav}</a></li>
    						<vb:else />
    						<li><a href="search.php?{vb:raw session.sessionurl}do=getdaily&amp;contenttype=vBForum_Post">{vb:rawphrase todays_posts}</a></li>
    						</vb:if>
    					</vb:if>
    					{vb:raw template_hook.navbar_after_getnew}
    					<vb:if condition="$show['pmmainlink']">
    						<li><a href="private.php{vb:raw session.sessionurl_q}" rel="nofollow">{vb:rawphrase private_messages}</a></li>
    					</vb:if>
    					{vb:raw template_hook.navbar_after_pm}
    					<li><a rel="help" href="faq.php{vb:raw session.sessionurl_q}" accesskey="5">{vb:rawphrase faq}</a></li>
    					{vb:raw template_hook.navbar_after_faq}
    					<li><a href="calendar.php{vb:raw session.sessionurl_q}">{vb:rawphrase calendar}</a></li>
    					{vb:raw template_hook.navbar_after_calendar}
    
    					<vb:if condition="$show['communitylink']">
    					<li class="popupmenu">
    						<a href="javascript://" class="popupctrl" accesskey="6">{vb:rawphrase community}</a>
    						<ul class="popupbody popuphover">
    							{vb:raw template_hook.navbar_community_menu_start}
    							<vb:if condition="$show['quick_links_groups']">
    								<li><a href="{vb:link grouphome}">{vb:rawphrase social_groups}</a></li>
    							</vb:if>
    							<vb:if condition="$show['quick_links_albums']">
    								<li><a href="album.php{vb:raw session.sessionurl_q}">{vb:rawphrase pictures_and_albums}</a></li>
    							</vb:if>
    							<vb:if condition="$bbuserinfo['userid']">
    								<li><a href="profile.php?{vb:raw session.sessionurl}do=buddylist"><vb:if condition="$show['friends_and_contacts']">{vb:rawphrase contacts_and_friends}<vb:else />{vb:rawphrase contacts}</vb:if></a></li>
    							</vb:if>
    							<vb:if condition="$show['memberslist']">
    								<li><a href="memberlist.php{vb:raw session.sessionurl_q}">{vb:rawphrase members_list}</a></li>
    							</vb:if>
    							{vb:raw template_hook.navbar_community_menu_end}
    						</ul>
    					</li>
    					</vb:if>
    					{vb:raw template_hook.navbar_after_community}
    					<li class="popupmenu">
    						<a href="javascript://" class="popupctrl">{vb:rawphrase forum_actions}</a>
    						<ul class="popupbody popuphover">
    							<li>
    								<a href="{vb:raw $vboptions.vbforum_url}{vb:if "$vboptions['vbforum_url']", '/', ''}forumdisplay.php?{vb:raw session.sessionurl}do=markread&amp;markreadhash={vb:raw bbuserinfo.securitytoken}" onclick="return confirm('{vb:rawphrase mark_forums_read_confirm}')">{vb:rawphrase mark_forums_read}</a>
    							</li>
                                                            <vb:if condition="$show['member']">
    							<li>
    								<a href="profile.php?{vb:raw session.sessionurl}do=editoptions">{vb:rawphrase edit_options}</a>
    							</li>
    							<li>
    								<a href="profile.php?{vb:raw session.sessionurl}do=editprofile">{vb:rawphrase edit_your_details}</a>
    							</li>
    							</vb:if>
    						</ul>
    					</li>
    					<li class="popupmenu">
    						<a href="javascript://" class="popupctrl" accesskey="3">{vb:rawphrase quick_links}</a>
    						<ul class="popupbody popuphover">
    							<vb:if condition="$show['member']">
    								<li><a href="search.php?{vb:raw session.sessionurl}do=getdaily&amp;contenttype=vBForum_Post">{vb:rawphrase todays_posts}</a></li>
    								<li><a href="{vb:link subscription}" rel="nofollow">{vb:rawphrase subscribed_threads}</a></li>
    								<li><a href="javascript://" onclick="window.open(getBaseUrl() + 'misc.php?{vb:raw session.sessionurl}do=buddylist&amp;focus=1','buddylist','statusbar=no,menubar=no,toolbar=no,scrollbars=yes,resizable=yes,width=250,height=300'); return false;">{vb:rawphrase open_contacts}</a></li>
    							</vb:if>
    							<vb:if condition="$vboptions['forumleaders']">
    							<li><a href="showgroups.php{vb:raw session.sessionurl_q}" rel="nofollow">
    		<vb:if condition="$vb_suite_installed">
    			{vb:rawphrase view_site_leaders}
    		<vb:else />
    			{vb:rawphrase view_forum_leaders}
    		</vb:if>
    	</a></li>
    							</vb:if>
    							{vb:raw template_hook.navbar_quick_links_menu_pos1}
    							{vb:raw template_hook.navbar_quick_links_menu_pos2}
    							{vb:raw template_hook.navbar_quick_links_menu_pos3}
    							<vb:if condition="$show['wollink']">
    								<li><a href="online.php{vb:raw session.sessionurl_q}">{vb:rawphrase whos_online}</a></li>
    							</vb:if>
    							{vb:raw template_hook.navbar_quick_links_menu_pos4}
    						</ul>
    					</li>
    					{vb:raw template_hook.navbar_end}
    				</ul>
    
    			</li>
    Try that


    WARNING: This will not display links to your SubPages if they exist. If you want both, then this will require more coding.
    Last edited by Dragonsys; 10-31-2011 at 06:39 PM.

  11. #11
    Join Date
    Jan 2008
    Location
    Atlanta, GA
    Posts
    444

    Default

    hmm looks like adv_portal_navtab_subpages is only called if there are existing subpages, so this probably will have to be in the adv_portal_navtab template instead.

  12. #12

    Default

    It worked on the CMPS page: http://quebecod.com. But, it's doubling up on all the other pages : s (forum index): http://quebecod.com/forum/forum.php.

  13. #13
    Join Date
    Jan 2008
    Location
    Atlanta, GA
    Posts
    444

    Default

    add
    Code:
    <vb:if condition="THIS_SCRIPT == 'CMPS'">
    to the top of the code and
    Code:
    </vb:if>
    to the bottom of it

  14. #14

    Default

    No, still not working : s I've tried adding the code to my adv_portal_navtab_subpages and my adv_portal_navtab with the if statement:

    <vb:if condition="THIS_SCRIPT == 'CMPS'">
    <!-- code // -->
    </vb:if>

  15. #15
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    You would need "THIS_SCRIPT == 'adv_index'" within your condition.
    Frequently Asked Questions
    CMPS Users Manual

    For vBadvanced software assistance, please use the support forums.
    Unsolicted PMs, IMs, and email will not be responded to.
    If you have a non-software related question or problem with your account, please submit a support ticket.

  16. #16

    Default

    Alright, that worked at 90%! Thank you Dragonsys and Brian for the support The style (CSS) is not being applied on my the adv_index: http://quebecod.com/index.php. If you compare with the forum index: the padding is not the same, the arrow icons are different and there is no hover bg color for 'community', 'Forum Actions' and 'Quick Links'. How can I achieve the common look and feel?

    Again thank you so much for the support! I am new to VB and VBA but it's the platform I want my site/forum/members to migrate to.

    Here is my code for adv_portal_navtab:

    <li<vb:if condition="$tabselected"> class="selected"</vb:if>><a href="{vb:raw vboptions.vba_portal_homeurl}<vb:if condition="$cmps_page['name'] == 'home'">{vb:raw session.sessionurl_q}<vb:else />?{vb:raw session.sessionurl}{vb:raw vboptions.vba_portal_pagevar}={vb:raw cmps_page.name}</vb:if>" class="navtab">{vb:raw cmps_page.title}</a></li>
    <vb:if condition="$subpagelinks">
    <ul class="floatcontainer">
    {vb:raw subpagelinks}
    </ul>
    </vb:if>
    <vb:if condition="THIS_SCRIPT == 'adv_index'">
    <li>
    <ul class="floatcontainer">
    {vb:raw template_hook.navbar_start}
    <vb:if condition="$show['searchbuttons']">
    <vb:if condition="$show['member']">
    <li><a href="search.php?{vb:raw session.sessionurl}do=getnew&amp;contenttype=vBForum_Post">{vb:rawphrase new_posts_nav}</a></li>
    <vb:else />
    <li><a href="search.php?{vb:raw session.sessionurl}do=getdaily&amp;contenttype=vBForum_Post">{vb:rawphrase todays_posts}</a></li>
    </vb:if>
    </vb:if>
    {vb:raw template_hook.navbar_after_getnew}
    <vb:if condition="$show['pmmainlink']">
    <li><a href="private.php{vb:raw session.sessionurl_q}" rel="nofollow">{vb:rawphrase private_messages}</a></li>
    </vb:if>
    {vb:raw template_hook.navbar_after_pm}
    <li><a rel="help" href="faq.php{vb:raw session.sessionurl_q}" accesskey="5">{vb:rawphrase faq}</a></li>
    {vb:raw template_hook.navbar_after_faq}
    <li><a href="calendar.php{vb:raw session.sessionurl_q}">{vb:rawphrase calendar}</a></li>
    {vb:raw template_hook.navbar_after_calendar}

    <vb:if condition="$show['communitylink']">
    <li class="popupmenu">
    <a href="javascript://" class="popupctrl" accesskey="6">{vb:rawphrase community}</a>
    <ul class="popupbody popuphover">
    {vb:raw template_hook.navbar_community_menu_start}
    <vb:if condition="$show['quick_links_groups']">
    <li><a href="{vb:link grouphome}">{vb:rawphrase social_groups}</a></li>
    </vb:if>
    <vb:if condition="$show['quick_links_albums']">
    <li><a href="album.php{vb:raw session.sessionurl_q}">{vb:rawphrase pictures_and_albums}</a></li>
    </vb:if>
    <vb:if condition="$bbuserinfo['userid']">
    <li><a href="profile.php?{vb:raw session.sessionurl}do=buddylist"><vb:if condition="$show['friends_and_contacts']">{vb:rawphrase contacts_and_friends}<vb:else />{vb:rawphrase contacts}</vb:if></a></li>
    </vb:if>
    <vb:if condition="$show['memberslist']">
    <li><a href="memberlist.php{vb:raw session.sessionurl_q}">{vb:rawphrase members_list}</a></li>
    </vb:if>
    {vb:raw template_hook.navbar_community_menu_end}
    </ul>
    </li>
    </vb:if>
    {vb:raw template_hook.navbar_after_community}
    <li class="popupmenu">
    <a href="javascript://" class="popupctrl">{vb:rawphrase forum_actions}</a>
    <ul class="popupbody popuphover">
    <li>
    <a href="{vb:raw $vboptions.vbforum_url}{vb:if "$vboptions['vbforum_url']", '/', ''}forumdisplay.php?{vb:raw session.sessionurl}do=markread&amp;markreadhash={vb:raw bbuserinfo.securitytoken}" onclick="return confirm('{vb:rawphrase mark_forums_read_confirm}')">{vb:rawphrase mark_forums_read}</a>
    </li>
    <vb:if condition="$show['member']">
    <li>
    <a href="profile.php?{vb:raw session.sessionurl}do=editoptions">{vb:rawphrase edit_options}</a>
    </li>
    <li>
    <a href="profile.php?{vb:raw session.sessionurl}do=editprofile">{vb:rawphrase edit_your_details}</a>
    </li>
    </vb:if>
    </ul>
    </li>
    <li class="popupmenu">
    <a href="javascript://" class="popupctrl" accesskey="3">{vb:rawphrase quick_links}</a>
    <ul class="popupbody popuphover">
    <vb:if condition="$show['member']">
    <li><a href="search.php?{vb:raw session.sessionurl}do=getdaily&amp;contenttype=vBForum_Post">{vb:rawphrase todays_posts}</a></li>
    <li><a href="{vb:link subscription}" rel="nofollow">{vb:rawphrase subscribed_threads}</a></li>
    <li><a href="javascript://" onclick="window.open(getBaseUrl() + 'misc.php?{vb:raw session.sessionurl}do=buddylist&amp;focus=1','buddylist','statusbar=no,menubar=n o,toolbar=no,scrollbars=yes,resizable=yes,width=250,height=300'); return false;">{vb:rawphrase open_contacts}</a></li>
    </vb:if>
    <vb:if condition="$vboptions['forumleaders']">
    <li><a href="showgroups.php{vb:raw session.sessionurl_q}" rel="nofollow">
    <vb:if condition="$vb_suite_installed">
    {vb:rawphrase view_site_leaders}
    <vb:else />
    {vb:rawphrase view_forum_leaders}
    </vb:if>
    </a></li>
    </vb:if>
    {vb:raw template_hook.navbar_quick_links_menu_pos1}
    {vb:raw template_hook.navbar_quick_links_menu_pos2}
    {vb:raw template_hook.navbar_quick_links_menu_pos3}
    <vb:if condition="$show['wollink']">
    <li><a href="online.php{vb:raw session.sessionurl_q}">{vb:rawphrase whos_online}</a></li>
    </vb:if>
    {vb:raw template_hook.navbar_quick_links_menu_pos4}
    </ul>
    </li>
    {vb:raw template_hook.navbar_end}
    </ul>

    </li>
    </vb:if>

  17. #17

    Default

    Is there a link to my CSS missing somewhere? Thanks for the help guys.
    Last edited by DFORMS; 11-16-2011 at 03:09 PM.

  18. #18

    Default

    ...this is a pain

  19. #19
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    The padding and such seems to be the same to me, so I'm assuming you were able to figure out the issue?
    Frequently Asked Questions
    CMPS Users Manual

    For vBadvanced software assistance, please use the support forums.
    Unsolicted PMs, IMs, and email will not be responded to.
    If you have a non-software related question or problem with your account, please submit a support ticket.

  20. #20

    Default

    thanks for all the info..guys
    @ Brian will this be in the next release?
    or should this of been working already ?
    Backup Backup Backup.. Thats all I can say

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Homepage not showing.
    By rwoscott in forum Troubleshooting & Problems
    Replies: 13
    Last Post: 03-09-2010, 05:10 PM
  2. Module not showing up on homepage
    By Chimpie in forum Troubleshooting & Problems
    Replies: 3
    Last Post: 06-13-2009, 11:31 AM
  3. why isn't the css gradient showing on homepage?
    By dannykilla in forum Troubleshooting & Problems
    Replies: 3
    Last Post: 09-02-2008, 02:02 PM
  4. Homepage not showing for a usergroup
    By nymyth in forum Troubleshooting & Problems
    Replies: 2
    Last Post: 07-31-2007, 11:08 AM
  5. Images Not Showing w/ Homepage
    By kaskade in forum Troubleshooting & Problems
    Replies: 4
    Last Post: 05-01-2006, 11:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •