Results 1 to 15 of 15

Thread: Call to undefined function print_portal_output()

  1. #1
    Join Date
    Aug 2005
    Location
    Durham, UK
    Posts
    177

    Default Call to undefined function print_portal_output()

    I've tried to access my site today, but receive the following error message:

    Code:
    [22-Oct-2013 21:04:47] PHP Fatal error:  Call to undefined function print_portal_output() in /home/******/public_html/sims/cmps_index.php on line 46
    Sim Fans UK - Sims downloads and discussion

  2. #2
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    Was the CMPS running fine before today? Have you disabled all plugins, or any of the CMPS plugins or the product in your Admin CP?
    Frequently Asked Questions
    CMPS Users Manual

    For vBadvanced software assistance, please use the support forums.
    Unsolicted PMs, IMs, and email will not be responded to.
    If you have a non-software related question or problem with your account, please submit a support ticket.

  3. #3

    Default

    Was there a solution to this? I just installed on 4.2.2. I get a similar error. Yes, the product and all plugins are active.

    Fatal error: Call to undefined function print_portal_output() in /var/www/virtual/enworld/forum/content.php on line 46

    (A search reveals dozens of threads with problems similar to this, but none with any solution in them).

  4. #4
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    Try going to the Mange Products link in your Admin CP, disable the CMPS product and then enable it again. If that doesn't help then you may want to double-check your $forumpath variable.

    http://www.vbadvanced.com/forum/faq....uble_forumpath
    Frequently Asked Questions
    CMPS Users Manual

    For vBadvanced software assistance, please use the support forums.
    Unsolicted PMs, IMs, and email will not be responded to.
    If you have a non-software related question or problem with your account, please submit a support ticket.

  5. #5

    Default

    I've not only done that a hundred times, I've installed and uninstalled the entire product more than once, too. The forumpath is correct.

  6. #6
    Join Date
    Apr 2006
    Posts
    1

    Default

    This is due to 4.2.2 by default, it's a warning.

    Add this:
    PHP Code:
    define('SKIP_ALL_ERRORS'true); 
    to your config.php and it'll solve the issue.

  7. #7
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    I'm not entirely sure what else the issue could be. If the suggestion above doesn't help and you'd like to submit a support ticket via the Members' Area here though I'll be glad to take a look at things for you.
    Frequently Asked Questions
    CMPS Users Manual

    For vBadvanced software assistance, please use the support forums.
    Unsolicted PMs, IMs, and email will not be responded to.
    If you have a non-software related question or problem with your account, please submit a support ticket.

  8. #8
    Join Date
    Aug 2005
    Location
    Durham, UK
    Posts
    177

    Default

    Sorry, only just seen these replies. It's happened again, so I've submitted a ticket.
    Sim Fans UK - Sims downloads and discussion

  9. #9

    Default

    Quote Originally Posted by angeljs View Post
    Sorry, only just seen these replies. It's happened again, so I've submitted a ticket.
    Let us know if it gets fixed - and how!

  10. #10

    Default

    Any luck there, angeljs?

  11. #11

    Default

    No?

  12. #12
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    Have you guys tried making sure that the CMPS product and all plugins for the CMPS are enabled in your Admin CP?
    Frequently Asked Questions
    CMPS Users Manual

    For vBadvanced software assistance, please use the support forums.
    Unsolicted PMs, IMs, and email will not be responded to.
    If you have a non-software related question or problem with your account, please submit a support ticket.

  13. #13

    Default

    Just thought I'd pop in a few months later and see if there was any progress.

    Quote Originally Posted by Brian View Post
    Have you guys tried making sure that the CMPS product and all plugins for the CMPS are enabled in your Admin CP?
    This question was answered prior to your post.

    Quote Originally Posted by Morrus View Post
    Was there a solution to this? I just installed on 4.2.2. I get a similar error. Yes, the product and all plugins are active.

    Fatal error: Call to undefined function print_portal_output() in /var/www/virtual/enworld/forum/content.php on line 46

    (A search reveals dozens of threads with problems similar to this, but none with any solution in them).

  14. #14
    Join Date
    Jan 2004
    Location
    Georgia, USA
    Posts
    34,466

    Default

    I don't see how it would be possible to get that error if your $forumpath variable is correct and the CMPS product and plugins are all active. I don't know much else to suggest, but if you'd like to submit a support ticket via the Members' Area here then I'll be glad to take a look at things for you.
    Frequently Asked Questions
    CMPS Users Manual

    For vBadvanced software assistance, please use the support forums.
    Unsolicted PMs, IMs, and email will not be responded to.
    If you have a non-software related question or problem with your account, please submit a support ticket.

  15. #15
    Join Date
    Aug 2005
    Location
    Durham, UK
    Posts
    177

    Default

    Okay, after all this time I've finally figured out what the problem is. I was working on another plugin, but when I came to save it, both CMPS and Dynamics went offline and gave errors on their pages. What had happened was that when I'd saved the plugin page, all of the vBadvanced plugins had become disabled, and they won't enable via the main page. I had to go to edit each one individually to set them as active. However, I'm still having problems as the init_startup (Dynamics) won't save because the PHP code box is blank!
    Sim Fans UK - Sims downloads and discussion

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Call to undefined function: print_portal_output() on line 44
    By 3dc in forum Troubleshooting & Problems
    Replies: 15
    Last Post: 09-06-2010, 08:40 AM
  2. Fatal error: Call to undefined function print_portal_output()
    By Pirat3 in forum Troubleshooting & Problems
    Replies: 1
    Last Post: 09-02-2008, 11:56 AM
  3. Call to undefined function print_portal_output() error
    By eam in forum Troubleshooting & Problems
    Replies: 2
    Last Post: 08-13-2008, 05:14 PM
  4. Fatal error: Call to undefined function: print_portal_output()
    By kidswap in forum Troubleshooting & Problems
    Replies: 5
    Last Post: 01-03-2007, 06:02 PM
  5. Call to undefined function: print_portal_output
    By destro3m in forum Troubleshooting & Problems
    Replies: 1
    Last Post: 06-11-2006, 06:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •